Error message

User warning: The following module is missing from the file system: fast_404. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1143 of /mnt/www/html/ooyala/docroot/includes/bootstrap.inc).

Preguntas frecuentes sobre la migración

Preguntas y respuestas frecuentes acerca de la migración al reproductor V3.

El reproductor de Ooyala presenta una forma nueva, más flexible y eficiente para embeber vídeos en páginas web. Esto significa que tendrá que cambiar el embebido de su página web. Este cambio afecta a todos los embebidos de JavaScript (independientemente de si utiliza un reproductor Flash o el reproductor HTML5).

P: ¿Cuál es el nuevo estilo de embebido?

R: Estamos avanzando a un estilo de embebido basado en objetos, que se asemeja a la manera de funcionamiento de otros entornos (como jQuery) orientados a objetos.

P: ¿Por qué se ha cambiado el estilo de embebido?

R: El nuevo estilo de embebido se ha diseñado para proporcionar un mejor rendimiento y capacidad de almacenamiento en caché. Es compatible con varios embebidos en una página -- el reproductor no se debe cargar por separado para cada embebido. Es más apto para desarrolladores -- se ajusta a los patrones a los que los desarrolladores están acostumbrados y funciona mejor con el típico diseño de los sitios web.

P: ¿Cambiarán las API del reproductor?

R: Las API del reproductor serán las mismas, pero cambiará la forma en que son llamadas en función de los nuevos embebidos.  También hemos añadido la API v2 de Backlot para HTML5 para acercarla en paridad a las API actuales del reproductor Flash.

P: ¿Cambiará el modelo de eventos?

R: Sí, ofrecemos un bus de mensajes para que los editores/creadores de módulos de terceros puedan reaccionar y/o personalizar el reproductor tanto como sea necesario.

P: ¿Puedo usar mi reproductor Flash con el reproductor de Ooyala actual?

R: Sí. Puede seguir utilizando Flash. El reproductor V3 proporciona un mecanismo de reserva, de manera que si Flash no está disponible o no es compatible con el dispositivo, se utiliza el reproductor HTML5. De lo contrario, se utiliza Flash.

P: ¿Puedo seguir utilizando ActionScript aunque embeba mi reproductor Flash mediante el nuevo reproductor?

R: Su reproductor Flash seguirá funcionando, pero no se admiten las llamadas de ActionScript. Puede interactuar con el objeto de reproductor Flash a través de las consultas a la API de JavaScript.

P: ¿Qué API puedo utilizar?

R: El reproductor de Ooyala cuenta con un conjunto de API de JavaScript que puede utilizar para personalizar la experiencia del reproductor. Estas se describen más adelante en este documento.